Back to overview
Degraded

Service Degradation Alert

Mar 14 at 03:19am PDT
Affected services
RFN Core Internet

Resolved
Mar 15 at 12:07am PDT

Issue has been resolved, and we will continue to monitor the system.

Created
Mar 14 at 03:19am PDT

There is a known issue regarding slow speeds and high latency, our engineers are investigating the issue and are working to resolve the issue as soon as possible.